Aide aux développeurs d'AutoCAD 2009

Bienvenue dans l'aide aux développeurs d'AutoCAD 2009

L'aide aux développeurs d'AutoCAD fournit des informations complètes pour personnaliser et étendre AutoCAD. Cliquez sur les liens à droite ou parcourez les rubriques d'aide à partir de l'onglet Sommaire.

Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF

Guide de programmation ActiveX et VBA

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

Mon aide
Ressources sur le Web


Aide d'AutoCAD 2009

Guide de personnalisation

Le Guide de personnalisation indique aux utilisateurs expérimentés comment personnaliser AutoCAD. Utilisez l'onglet Sommaire, à gauche de la fenêtre d'aide, pour parcourir le Guide de personnalisation.

  • Personnalisation de base
  • Types de ligne personnalisés
  • Motifs de hachures personnalisés
  • Personnalisation de l'interface utilisateur
  • DIESEL
  • Clichés et scripts de commande
  • Introduction aux interfaces de programmation
  • Formes et polices de forme
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF

Guide de programmation ActiveX et VBA

ActiveX and VBA Reference


AutoLISP Reference

Le manuel AutoLISP Reference fournit des informations complètes sur AutoLISP®, un langage de programmation d'interprétation complet que vous pouvez utiliser pour lancer les commandes, les variables système et les boîtes de dialogue AutoCAD. Vous y trouverez les rubriques suivantes :

  • AutoLISP Functions: Operators, A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • Externally Defined Commands
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


AutoLISP Developer's Guide

Le manuel AutoLISP Developer's Guide fournit des informations sur l'utilisation de l'environnement de développement interactif de Visual LISP® pour développer et tester des programmes AutoLISP®. Il décrit également l'utilisation des extensions fournies avec Visual LISP pour créer une automatisation ActiveX®. Vous y trouverez les rubriques suivantes :

  • Introduction
  • Using the Visual LISP Environment
  • Using the AutoLISP Language
  • Working with Programmable Dialog Boxes
  • Appendixes
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


AutoLISP Tutorial

AutoLISP Tutorial fournit des leçons pas à pas vous indiquant comment utiliser Visual LISP™ pour développer une application AutoLISP®. Vous y trouverez les rubriques suivantes :

  • Introduction
  • Designing and Beginning the Program
  • Using Visual LISP Debugging Tools
  • Drawing the Path Boundary
  • Creating a Project and Adding the Interface
  • Drawing the Tiles
  • Acting with Reactors
  • Putting It All Together
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


Manuel d'utilisation DXF

Le Manuel d'utilisation DXF donne des informations complètes sur le format DXF™. Vous y trouverez les rubriques suivantes :

  • Format DXF
  • Section HEADER
  • Section CLASSES
  • Section TABLES
  • Section BLOCKS
  • Section ENTITIES
  • Section OBJECTS
  • Section THUMBNAILIMAGE
  • Formats de fichiers d'échange de dessins
  • Concepts DXF avancés
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


Guide de programmation ActiveX et VBA

Le Guide de programmation ActiveX et VBA explique comment utiliser ActiveX et VBA afin de développer une application permettant de personnaliser AutoCAD. Ce guide comprend également des exemples de code et des procédures pas à pas. Vous y trouverez les rubriques suivantes :

  • Introduction
  • Démarrage avec VBA
  • Fondements de l'automatisation ActiveX
  • Contrôle de l'environnement AutoCAD
  • Création et modification d'entités AutoCAD
  • Cotes et tolérances
  • Personnalisation des menus et barres d'outils
  • Evénements
  • Travail en 3D
  • Définition de présentations et traçage
  • Techniques avancées de dessin et d'organisation
  • Développement d'applications avec VBA
  • Interaction avec d'autres applications et API Windows
  • Exercice ActiveX/VBA: Conception d'un sentier de jardin
  • Comparaison de Visual LISP avec ActiveX/VBA
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


ActiveX and VBA Reference

Le manuel ActiveX and VBA Reference fournit des informations sur le modèle d'objet ActiveX et à ses composants d'interface associés. Vous y trouverez les rubriques suivantes :

  • Object Model
  • Events
  • Methods
  • Properties
  • Objects
  • Code Examples
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


Sheet Set Objects Reference

Le document Sheet Set Objects Reference donne des informations sur les objets du gestionnaire du jeu de feuilles. Vous y trouverez les rubriques suivantes :

  • Overview of Sheet Set Manager Objects
  • Objects
  • Methods
  • Properties
  • Enums
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


Connectivity Automation Reference

Le document Connectivity Automation Reference donne des informations sur le modèle objet Connectivity Automation et les composants logiciels associés. Vous y trouverez les rubriques suivantes :

  • Connectivity Automation Objects
  • Object Model
  • Objects
  • Methods
  • Properties
  • Events
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


ObjectARX

ObjectARX®, l'environnement de programmation AutoCAD® Runtime Extension, comprend des bibliothèques C++ qui sont les éléments de base vous permettant de développer des applications AutoCAD, d'étendre les classes et protocoles AutoCAD et de créer de nouvelles commandes qui fonctionneront de la même façon que les commandes intégrées d'AutoCAD.

Si cet élément d'aide s'affiche sous la forme d'une icône de page ( [image]) sur l'onglet Sommaire, cela signifie que la documentation ObjectARX n'est pas encore disponible dans le système d'aide.

Vous pouvez télécharger la documentation AutoCAD ObjectARX à partir de la section Centre des développeurs du site Web d'Autodesk. Pour intégrer la documentation ObjectARX à votre documentation AutoCAD, copiez les fichiers de l'aide ObjectARX dans le dossier AutoCAD\HELP\.
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


Mon aide

Vous pouvez créer votre propre groupe de rubriques : Mon aide. Une fois que vous avez ajouté les rubriques Mon aide à l'aide d'AutoCAD, elles sont disponibles dans les onglets Sommaire, Index (si vous ajoutez des entrées d'index) et Rechercher dans le panneau gauche de la fenêtre d'aide. Cliquez sur la rubrique Mon aide dans l'onglet Sommaire pour accéder à la rubrique que vous avez ajoutée à l'aide d'AutoCAD.

Pour plus d'informations concernant la configuration de Mon aide, reportez-vous à Configuration de Mon aide.
Informations générales

Fichiers d'aide

Guide de personnalisation

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

Manuel d'utilisation DXF


Envoyez-nous vos commentaires

Utilisez ce formulaire pour envoyer vos commentaires à l'équipe de rédaction technique d'Autodesk responsable de cette documentation.

Titre et emplacement de la rubrique (ne pas modifier) :
Nom (facultatif) :
         Adresse électronique (facultatif) :
Commentaires :

Remarque : ce formulaire n'est pas prévu pour demander une assistance technique. Vos informations seront utilisées pour améliorer les prochaines mises à jour de la documentation. Merci


Copyright et marques commerciales

© 2008 Autodesk, Inc. Tous droits réservés. Cet ouvrage ne peut être reproduit, même partiellement, sous quelque forme ni à quelque fin que ce soit.

Certains des éléments de cet ouvrage ont été ré-imprimés avec l'accord du détenteur des droits d'auteur.

Marques

La liste suivante regroupe les marques ou les marques déposées d'Autodesk, Inc., aux Etats-Unis et/ou dans d'autres pays : 3DEC (conception/logo), 3December, 3December.com, 3ds Max, ActiveShapes, Actrix, ADI, Alias, Alias (conception/logo spirale), AliasStudio, Alias|Wavefront (conception/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer, Create>what’s>Next> (conception/logo), Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio (conception/logo), Design Your World, Design Your World (conception/logo), DWF, DWG, DWG (logo), DWG TrueConvert, DWG TrueView, DXF, EditDV, Education by Design, Extending the Design Team, FBX, Filmbox, FMDesktop, Freewheel, GDX Driver, Gmax, Heads-up Design, Heidi, HOOPS, HumanIK, i-drop, iMOUT, Incinerator, IntroDV, Inventor, Inventor LT, Kaydara, Kaydara (conception/logo), LocationLogic, Lustre, Maya, Mechanical Desktop, MotionBuilder, ObjectARX, ObjectDBX, Open Reality, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, ProjectPoint, Reactor, RealDWG, Real-time Roto, Render Queue, Revit, Showcase, SketchBook, StudioTools, Topobase, Toxik, Visual, Visual Bridge, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Syllabus, Visual Toolbox, Visual Tugboat, Visual LISP, Voice Reality, Volo et Wiretap.

Les marques suivantes sont des marques déposées ou commerciales d'Autodesk Canada Co. aux Etats-Unis et/ou dans d'autres pays : Backburner, Discreet, Fire, Flame, Flint, Frost, Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone et Wire.

Tous les autres noms de marques, noms de produits et marques commerciales sont la propriété de leurs détenteurs respectifs.

Limitation de responsabilité

CET OUVRAGE ET LES INFORMATIONS QU'IL CONTIENT SONT FOURNIES PAR AUTODESK, INC. "EN L'ETAT". AUTODESK, INC. FOURNIT CES ARTICLES SANS GARANTIE D'AUCUNE SORTE, NI EXPRESSE, NI IMPLICITE, Y COMPRIS ET SANS LIMITATIONS, LES GARANTIES IMPLICITES D'ADAPTATION COMMERCIALE ET D'APTITUDE A UNE UTILISATION PARTICULIERE.


Configuration de Mon aide

Configurer mon aide

Si vous souhaitez configurer Mon aide, vous devez créer vos rubriques d'aide en langage HTML, puis les compiler à l'aide de l'atelier d'aide Microsoft HTML Help Workshop pour créer un fichier d'aide compilé appelé myhelp.chm. Copiez ce fichier dans le dossier AutoCAD\Help.

Pour afficher des titres de rubriques avec hyperliens dans la rubrique principale de Mon aide

  • Intégrez un fichier répertoriant tous les titres de ces rubriques dans le fichier CHM. Appelez ce fichier myhelp_toc.html.

Pour afficher les titres des rubriques dans l'onglet Sommaire

  • Intégrez un fichier HHC (Help Contents) répertoriant tous les titres de ces rubriques dans le fichier CHM.

Pour afficher toutes les entrées d'index ajoutées à vos rubriques d'aide

  • Intégrez un fichier HHK (Help Index) dans le fichier CHM.

Même si vous n'avez pas intégré le fichier myhelp_toc.html, HHC ou HHK, le contenu de votre fichier CHM est disponible dans l'onglet Rechercher.


zz [Rubrique vide]

Rubrique vide

Cette rubrique est laissée intentionnellement vide.